How do I convert an Access database to a MySQL database?

The following article explains how to convert an Access database to a MySQL database. Before you begin, you will need to create a MySQL database (a free MySQL database is included with all HostMySite’s hosting plans that support Access). Instructions for creating your MySQL database can be found here.

Note: The name of the Access database must match the name of the MySQL database, so it may be necessary to rename the Access database file.

To convert an Access database to a MySQL database, please follow these steps:

  1. Load http://dev.mysql.com/downloads/workbench/ in a browser and click Download the MySQL Workbench. Load http://mysql.com/products/tools/migration-toolkit/ and click Download kit.
  2. Select the appropriate file based on your local machines operating system. Select the appropriate file based on your local machines operating system.
  3. Scroll to the bottom and select a mirror site close to your location and click the available link for http or ftp. Scroll to the bottom and select a mirror site close to your location and click the available link for http or ftp.
  4. When the install file completes downloading, install the toolkit following the instructions in the installation wizard.
  5. Load http://java.sun.com/javase/downloads/index.jsp in a browser and click Download for Java Runtime Environment (JRE) 5.0 Update 8. Load http://java.sun.com/javase/downloads/index.jsp and click Download for Java Runtime Environment (JRE) 5.0 Update 8.
  6. Click Accept License Agreement. Click Accept License Agreement.
  7. Click Windows Offline Installation, Multi-language to download the JRE.
  8. When the install file completes downloading, install the toolkit following the instructions in the installation wizard.
  9. Open the Access database you wish to convert. If the Access database name does not match the MySQL database name, you will need to rename the Access database file.
  10. From the Tools menu, select Options. From the Tools menu, select Options.
  11. On the View tab, click System Objects and click OK. On the View tab, under Show, click System Objects and click OK.
  12. From the Tools menu, click Security and select User and Group Permissions. From the Tools menu, click Security and select User and Group Permissions.
  13. Select MSsysObjects, click Administer and click Apply. Select MSsysObjects, click Administer and click Apply.
  14. Repeat the previous step for MSusQueries and MSysRelationships.
  15. Click OK.
  16. Click Start, Programs, MySQL, MySQL Migration Toolkit to open the toolkit. This is the default location for the toolkit. Click Start, Programs, MySQL, MySQL Migration Toolkit to open the toolkit.
  17. Click Next to begin the wizard
  18. Select Direct Migration and click Next. Select Direct Migration and click Next.
  19. Enter the requested source information and then click Next:
    • Database System: select MS Access
    • Database File: browse to your Access database
    • Username: enter the username for your Access database (if applicable)
    • Password: enter the password for your Access database (if applicable)

    Enter the requested source information and then click Next:

  20. Enter the requested destination information and then click Next:
    • Database System: MySQL Server
    • Hostname: enter the name of the MySQL server that contains your MySQL database
    • Username: enter the username for your MySQL database
    • Password: enter the password for your MySQL database

    Enter the requested destination information and then click Next:

  21. Click Next after the Connecting to Servers tasks complete.
  22. Select your database from the list of schema and click Next. Select your database from the list of schema and click Next.
  23. Click Next after the Reverse Engineering tasks complete.
  24. Select each object type to convert and click Next. Select each object type to convert and click Next.
  25. Select Generic for each Migration Method and click Next. Select Generic for each Migration Method and click Next.
  26. Click Next after the Migration tasks complete.
  27. Click Next after the scan for mapping problems complete. Click Next after the scan for mapping problems complete.
  28. Select Create Objects Online and click Next. Select Create Objects Online and click Next.
  29. Click Next after the Creating Objects tasks complete.
  30. Click Next after the scan for creation problems complete. Click Next after the scan for creation problems complete.
  31. Select Transfer Data Online and click Next. Select Transfer Data Online and click Next.
  32. Click Next after the Bulk Data Transfer tasks complete.
  33. Click Finish to exit the migration toolkit.